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1. Introduction

FrontPage 2000 is a program to help you build a web site easily with a minimum
knowlege of the code HTML (hypertext markup language) which underlies all web sites.

Please review TTU’s World Wide Web Publication Policy before beginning your pages.
This is available from the TTU home page under About this Web Server — How to
Become a TTU Web Provider » World Wide Web Publications Policy
(www.tntech.edu/www/gen/web_publish/policy.html).

2. Design Considerations

Before you begin, you will want to have some ideas about how you would like your page
to look. You can get ideas by looking at both good and poor examples on the internet.
Refer to the Web Style Guidelines available from the TTU home page under About this
Web Server - How to Become a TTU Web Provider -~ Web Style Guidelines
(www.tntech.edu/www/gen/web_publish/style_guide.html). You can also contact the TTU
Office of Public Affairs (ttunews@tntech.edu) or Information Technology Services
(Ineal@tntech.edu) for additional suggestions.

In designing your page:

1. Develop a plan for your pages. Who is your target audience?
What messages and/or information are you trying to deliver using the
web page(s)? How will the pages relate to your objectives?

2. Sketch an outline of how you would like your pages to look.
3. Construct a preliminary site and evaluate what you have.

4. Test your pages using more than one web browser, such as Internet
Explorer or Netscape Communicator.

5. Revise your design.

6. When complete, notify other people that your web page is now online.
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3. Opening FrontPage 2000

In the labs from the Start menu, select Programs - MSOffice 2000 — Microsoft FrontPage.

Note that the program opens a new blank page for you in Page view. This is the basic text
and layout editor for formatting your web page content.
At the bottom of the sheet are three tabs:

Normal This is the view in which you develop and edit your pages.

HTML  View and edit the HTML code of your document. If you are familiar with HTML,
there may be some tasks that you are more comfortable performing here.

Preview Displays a close approximation of what visitors to your site will see through their

Web browser. NOTE: The preview tab is an approximation and cannot mimic with 100% accu-
racy what visitors to your site will see.

Before you begin, click on the HTML tab. You will see some beginning code is already
present that defines this page as an HTML document. Click back to the Normal tab.
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4. Toolbars

Formatting Toolbar

Note the familiar formatting toolbar which includes the following:

Style

Font

Font Size

Bold

Italic

Underline

Align Left
Center

Align Right
Numbering
Bullets
Decrease Indent
Increase Indent
Highlight Color
Font Color

Standard Toolbar

A drop-down menu that allows you to change the text style. It in-
cludes the heading styles 1 to 6, bulleted and numbered list and
other options.

A drop-down menu that allows you to change the text font. If you
select default, the text font will default to that selected by the user for
his/her browser. Remember to select common fonts found on
both PCs and Macintosh computers for the broadest access to
your page as you designed it.

A drop-down menu that allows you to change the size of the font
Bold faces fonts

Italicizes fonts

Underlines fonts

Aligns text with the left margin

Centers text horizontally across the page

Aligns text with the right margin

Creates an ordered list (i.e., 1., 2., 3., 4., etc.)

Creates an unordered list (i.e., a bulleted list)

Sets the current margin for lines of text further to the left

Sets the current margin for lines of text further to the right

Sets the background color of the selected object or text

Sets the font color

The standard toolbar includes:

New Page
Open

Save

Publish Web
Folder List
Print

Preview in Browser
Spelling

Cut

Copy

Paste

Format Painter

Opens a new blank page for editing

Opens an existing page for editing

Saves the current page to your local machine or network
Saves and uploads the current page to your Web server
Displays a list of your folders

Prints the current page

Displays the current documents in your default Web browser
Checks spelling

Removes information and stores it in clipboard

Copies information and stores it in clipboard

Pastes information stored in clipboard at location of cursor
Copies HTML format to text
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4. Toolbars (cont.)

Standard Toolbar

Undo Undoes last command
Redo Redoes last undo
Insert Component Inserts FrontPage 2000 specific components
Extensions on the Web server)
Insert Table Inserts a table

(requires FrontPage

Insert Picture From File Inserts pictures or graphics from your local computer

Hyperlink Inserts a hyperlink
Refresh  Refreshes the screen
Stop  Stops loading page in preview mode
Show All  Displays all hidden formats
FrontPage Help Displays the FrontPage Help menu

5. Creating a Web

* From the menu, select File > New - Web
» Under Web Sites, select Empty Web

* Type the name for your new web:

U:\SampleWeb 4

File Edit “iew |nsert Format Tools Table Fram

[0 Page.. Cirl+M

* Click OK = Dpen... Cirl+0
* Note the message that SampleWeb Close Ctrl+F4
is being created. i ey
New 7| x|
Web Sites |
= [, e 7, o e
5] oy ®] gy =
One Page Corporate Custammer Dizcuzsion Opticrs
Wwheb Fresen... Support'web  wieb'Wwizard Specify the location of the new web:
0 N, 0 [g ILI:'\SampIeWeI:: ;I
— — I — —
. . vala[ls =]
Empty *eb  Import'web  Personal™eb  Projectweb - e : - :
‘wizard I™ | Secure conmection required (S5
\ Specify location Description
Select Empty Web Create a new web with nothing in it.
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5. Creating a Web (cont.)

Adding Pages
Your Web Site has been established. Now you need to add pages to it.
. . . Eile Edit “iew |
* Click on the New Page icon in the toolbar to create a new page. =~ -
» Type the name of your department or organization on the first OG-
line. For now, this will be coded as the title of your page. New Page|'
* Click on the Save icon and save as index.htm -

This will be your home page.

* Click on the New Page icon to create the following pages.

Eile Edit| View Insert Format
Type on the Page Save the file as e
News News Hlﬁ Eage
Personnel Personnel Nomal | £ Eolders
Programs Programs ([ Beports 3
Program1 Program1 VIEWS g Navigation
Program2 Program2 3% Hypetlinks
Program3 Program3 (7 Tasks
* From the menu, select View = Folder List to see a list |T Views Bar

of files and folders in your site, next to the view of your
page.

Folder List

Setting Page Titles

* In the folder list, double-click on the file index.htm to begin editing it.

* Click on the HTML tab to see that some code has already been created for you.
Note that the first words you typed on your page were picked up as the Title of your
page. This is what appears in browser headers and as bookmarks or favorites.

* Click on the Normal tab

* Right click on the page. g;t
» Select Page Properties from the floating menu. Pazﬁ;

» Change the title of your page here if needed. _
Faste Special

Page Properties Theme...

Shared Borders...

General | Bau:kgru:uundl Marginsl Eustu:uml Languagel Wu:urkgru:uupl

Fage Froperies...

Fant...

Location: Ifile:aWLl:a’S ampleitfebdindes. htm

Title: |nformation Technolagy Services

Baze location: I
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6. Entering content on your pages
- (d
» Select your department name or other title. (None) il
« Using the Style pulldown menu on the formatting toolbar, E;'rrrr::tlted =
select an appropriate size. =T Address -
- ’;E Heading 1
» Center the heading using the center icon in the toolbar.
Heading 3

* To insert a horizontal rule,

from the menu, select Insert > Horizontal Line.

Heading 4 j

* Right-click on the line and select Horizontal Line Properties from the pop-up menu.
 Select the characteristics of your line including width in percent and color.

» Type a paragraph about your department or area. Try different

formatting effects, such as bold, ifalics, and underline

» Type a second paragraph and use the increase indent

to set it off from the first paragraph.

=2 A

== =
Bullets| Increase Indent

* Insert another horizontal line. From the menu, select Insert > Horizontal Line.
» Note that your property selections are maintained.

o =
» Save your work. From the menu, File = Save or use the icon in the toolbar.

* Double-click on your Programs file.
* List your Programs in a bulletted list.

» Use the bullet icon in the formatting toolbar.

* Double-click on your Personnel file.

Sawe

Ak
]
1|

=[+-A-.

7 =
Bullets| Increase Indent|

* List your Faculty and Staff using a numbered list.
» Use the numbered list icon in the formatting toolbar.

Capturing and adding a graphic

)
* Minimize FrontPage and open Internet Explorer u

Intertet

Explarer

* From the TTU Home Page, select Welcome Center - TTU Highlights and Facts

« Scroll to the bottom of the page.
* Right-click on the small house image.

* From the floating menu, select Save Picture As.

£

* Browse to the U: drive, accept the suggested filename home.gif

* Click Save.

* (Or browse to ClassFiles on Athena - ITS - FrontPage — home.gif

Select the file and click OK.)
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6. Entering content on your pages

Capturing and adding a graphic

* Click on FrontPage in the task bar to bring it into view.
* Double-click on your file index.htm in the folder list.

i ]| O MR A

* To insert the little house image: From the menu, |§ [am o— = 3
select Insert - Picture - From File MO PSS e (FlD
Or on the standard toolbar, click on the Import Picture from File icon.

* Browse to the U: Drive and select the file

* Click OK.

To insert a link to the TTU home page:

* Next to the house graphic, type TTU Home Page
* Highlight the picture
* From the menu, select Insert = Hyperlink
or right-click and select Hyperlink from the pop-up menu.
* In the URL box near the bottom, type www.tntech.edu
* Click OK
« Highlight the short phrase and repeat these steps.

Type URL |Make a hypetlink to a file onyour n::n:lmputer|
URL: |http:£fwww_ thtech.edu Q @lﬂ E
Optional !Make a hyperlink that sends E-rnail
’V Bookmark: I[HDHE] LI T arget frame: IF'E'EIE Default [nane)] ﬂ
—-—-—’ITI Cancel | Parameters... | Style... |

To insert an email link:

» Type: This page is maintained by Your Department
* Highlight Your Department

* From the menu, select Insert = Hyperlink

* Click on the envelope icon (see above)

» Type your email address. s -
. CSIIti):k éK Create E-mail Hyperlink 7] %]
* Click OK. Type an E-mail addres= E xample: someone@ricrosoft. com

|| ewells{@ntech.edu

— k. I Cancel
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6. Entering content on your pages (cont.)

To insert a WebBot that automatically notes last update:

Date and Time Properties 7 x
» Type: Last updated on Display: /
* From the menu, % Date this page waz last edited
select Insert - Date and Time ' Date this page was last automatically updated
* From the pulldown menu, select a
date format D ate format: 02M12/2002 ;I
e Cli : 02A2/2002 “
Click OK. Time farmat: |7 yesday, February 12, 2002
g February 12, 2002
12 February, 2002 el |
12 Feb 2002 s |

Save your file and look at it in a browser:
=
* From the menu, select File > Save or use the icon in the toolbar.

SaEve

* Maximize Internet Explorer

* From the menu, select File > Open

* Click on the Browse button and locate your file index.htm on the U: drive
* Highlight the file to select it and click Open

* You should now see your page as it would appear on the web

7. Navigation View

To this point, we have only dealt with the Page editing view. Next we will explore the
Navigation view.

* Click on the Navigation view icon.

* In this view, you will see the structure of your web.
At this point, it only has one file, index.htm, which
has the title of your Department.

Mawigation

To change the name for this file as it will appear in the shared borders links:
" phick on the fabel
Department, pause slightly avgeion

and click again to select. 100% e

» Type to change the name
of this page as it will Department D|
appear in navigation bars. {ah

This wiew shows the navigation structure of your Web, To
automaticaly add navigation buttons to these pages,
choose Shared Borders on the Format men,
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7. Navigation View (cont.)

To include other files and build links:

» Select the programs.htm file in the folder list

* Drag it under Your Department in the Navigation view.

* Note that a link is created from Your Department to Programs.

* Do the same for the news.htm and personnel.htm files. Note that you may drag and
position these in any order. The order will later be reflected in your navigation bars
as you add these to your pages.

* Next, drag the files program1.htm, program2.htm, and program3.htm under
Programs.
* You can change the navigation names of any of the pages from this view.

Note that the filename can be different from the Title of the page, and the Title of the
page can be different from the label which will show up in the Navigation bars.

Your structure should now look like this:

Department D|
o S -
I | I N I .
Amouncem...hl Events t’I Faculty and ... Frograms
-
I I
& &
Frogram 1 Frogram 2 Frogram 3 b|

As your structure becomes more elaborate, it is some-

times helpful to have an enlarged view. |m v 150%
Rotate 100%0
* Right-click on your navigation page Expand Al 7504
* Select Zoom from the popup menu. Yiew Subtree Orly 50%
» Select the Zoom level that will best help you see 2504
your links and overall structure. MNew Top Fage Size To Fit
Soply CHanges
Web Sefttings...

Return to Page view

In the next class we will discuss how to produce navigational links on your pages.
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8. Getting Help

* To learn more about HTML and publishing on the world wide web, check out some of
the online resources available as links from the TTU Home Page - Web Publishing
Info  http://www.tntech.edu/www/gen/web_publish/html.html

* The home page of the World Wide Web Consortium (W3C®) which oversees the
development of Hypertext Markup Language and other topics relating to the web is
found at:  http://www.w3.org/

* You will also want to validate your page to check for any errors in coding by
submitting each page's URL to the validator program at the W3C:

http://validator.w3.org/

* Information on making web pages more accessible is also available at the W3C site:

http://www.w3.org/WAIl/

* To learn more about Microsoft FrontPage:

From the menu select Help - Microsoft FrontPage Help.

 To request a web directory for a department, organization, or for instructional
materials, please fill out an application form available from the TTU Home Page -

Computing > Forms - Web Directories

i - o BEF

X Microsoft FrontPage Help !Elm

Contents |&nswerWizard | Inclex |

@ Designing Webs
@ Authoring HThL
@ Analyzing Webs

@ Publishing Webs
@ Managing Webs

@ Designing Web Pages

@ Ensuring Web Cormpatibility

@ Using FrontPage in Warkgroup
@ Using FrortPage with Office

@ Getting Around in FrontPage  —

w1 B Ah At e M ol
4 | | >

ICroso

Welcome to Help

* Lze online Help to learn more
about FrontPage 2000 features

* Quickly find answers to questions
using the Answer Wizard

* Connect to the Web for the latest
tips and product updates
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Summary of Common HTML Tags

HTML Tag

Brief Description

<HTML>Your entire page</HTML>

Identifies the page as a web page.

<HEAD>Heading Information</HEAD>

Identifies the heading area of the page.

<TITLE>Title of the Page</TITLE>

The title which appears in the title bar.

<BODY>Body of the Page</BODY>

Identifies the body area of the page.

<H1>Text</H1> Heading Text. H1 through H6 available.
<HR> Inserts a line in your document.
<B>text</B>
<strong>text</strong> Bolds the text.
<I>text</I> -
Italicizes text.
<em>text</em>
<U>text</U> Underlines text. (deprecated)

<PRE>Preformatted text</PRE>

Displays text exactly as you typed it.

<P>Paragraph

Paragraph break (double space).

<BR>Line Break

Line Break (single space).

<UL></UL> Unordered/bulleted list.
<OL></0OL> Ordered/numbered list.
<LI> List item.

<IMG SRC="filename.gif" ALT="text">

Inserts a graphic in your page.

<ADDRESS>Text</ADDRESS>

Contains the signature of your page.

<A HREF="locationURL">Link Name</A>

Link to another page.

Other Useful HTML Codes

Character Numeric Code
. &#183;
& &#38;
© &#169;
® &#174;

Description
Middle dot

Ampersand
Copyright
Registered trademark
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