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1. Introduction

Several formatting options are easily accomplished in FrontPage 2000. This handout will
discuss the use of shared borders, tables, handling images and graphics, and working with
themes.

2. Shared Borders

You can apply the same elements to all of your web pages by using shared borders. These
borders may include navigational links, some text or an image that defines your overall site.

Open the web you created in the last class:

 In the labs, from the Start menu: Programs — MSOffice 2000 -~ Microsoft FrontPage
« From the menu, select File > Open Web

* You should see your web on the U: drive (otherwise browse to locate your web).

« Click Open.

« From the Folder List, double-click on index.htm to open it in Page view.

Add a shared borders to the top. left, and bottom of each page.

e From the menu, select Format - Shared Borders

Shared Borders
« Select Apply to: © All Pages 2]
Apply bo;
Select top, left,
4| Top & &l pages / and bottarn barders.
Avoid borders
M Include " Curent page ot the right.
navigation buttons
J "l A
M Left — ¥ Include navigatifn buttons
-
M Include - W Left
nawgatlon buttons I ¥ Include naffigation buttons
M Bottom L I Right
¥ Battom
e Click OK.
I™ | Feset Barders fan cument page towet derault
k. I Cancel
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2. Shared Borders (cont.)
Editing your top shared border: Page Banner Properties EHE
. . Froperti
* Right-click on the Page Banner created operiEs
in your top shared border. " Picture
* From the pop-up menu, select Page * Test
Banner Properties
- Edit the text as needed. Feme (e =
* Click OK. IInfl:nrmatiDn Technology Services
Note: Do not edit the text directly in page
view. You can also easily edit these banners 0K I Cancel
in the Navigation View

 Highlight the Page Banner text and
select an appropriate font, font color, and style from the toolbar
or by right-clicking on the text and selecting Font from the pop-up menu.
* Move your cursor to the end of the Page Banner text.
* From the menu, select Insert - Horizontal Line
* Right-click on the line and select Horizontal Line Properties from the pop-up menu
» Select appropriate properties including width, height, and color
* Click into the body of your page and remove the heading and horizontal line since these

are now in the top shared border.

Adding navigational links

In the top navigation bar, we will set the navigation links to be those at the same level in the

hierarchy as the page we are viewing

. For the left navigation bar, set the links to the next

level down in the hierarchy (child level).

* In the top shared border,
right-click on: [Edit the prop-
erties for this Navigation Bar
to display hyperlinks here]

 In the menu, left-click on
Navigation Bar Properties

In the properties box, set the links:

© Same level
Additional pages:
M Home page
M Parent page
Orientation and appearance
©®© Horizontal
© Buttons
Click OK.

Navigation Bar Properties

Hypetfinks to add to page
" Parent level

¥ Same level
™ Back and

(-

i

™ Top level

Addtional pages:

* Home page
next ¥ Paent page
" Child level

" Child pages undes Home

O Page navigation bars will appear on
B FPages navigation bars will link to
(&) Home page

] Other pages

Orientation and appealance

—

— \

* Horizontal (* Buttons
" Yeitical ™ Test
Carce
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2. Shared Borders (cont.)

You will not see any links on your index.htm page, because there are no other pages at
that level. Double-click to open one of the other files and note that the top shared border
includes links to same level pages as well as to your home page and parent level.

Adding navigational links to the left shared border [Hypetinks to 23d to page

€ Patent level

« Return to the index.htm file .S #L0

« Right-click on the links in the left border. L] ot aina

* In the floating menu, left click on a4 : i b
Top level

igati i
Navigation Bar Properties P P

In the properties dialog box, set the links: £ Page navigation bars wil appear on
B Page: navigation bars will link o
® Child level @) Home page
Orientation and appearance , |_| e
® Vertical e
© Buttons i= » Hr-img/\ € Butons
Click OK. - & Verical C Text

Explore your files to see if you can predict which will include links in a left shared border.
Hint: Refer back to your navigation view to see which files have “children.”

Editing your Navigation labels

+ Click on Navigation view.

* Click on the icon Personnel

+ Click again to edit the title and rename it, such as ITS Staff

* Return to Page view and note the effects in the shared borders.

Remember to edit your Navigation links in the Navigation view, not in Page view.

Adding information to the bottom border

It is helpful to include some information on each page as to who maintains the page and
when it was last updated and any copyright information.

* Return to the index.htm file
* In the body of your page, select the house graphic and link to TTU Home Page which
you added in the last session [T [

« Drag it into the bottom shared border. B5ETTU Home Page!
R BeIOW that, Insert a horizontal Iine e T -

» Select the text Maintained by TS

Maintained by: ITS Last Updated: February 14, 2002
Last Updated: February 14, 2002 P ' v

* Drag it into the bottom shared border below the horizontal line.
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2. Shared Borders (cont.)

* Note that this information will appear in the bottom of each of your pages.
* You may also wish to add copyright information in this area.

To omit a shared border on a specific page: Shared Borders

Apply to;

» Double-click to open the file Program2.htm " Al pages

* From the menu, select Format - Shared Borders p /
* Current page

» Select ® Current page

+ Deselect Bottom | e | [ Top
» Deselect Top _I, F inci
* View the results. -
- v Left
You might wish to delete the bottom shared border for a : e Slci]
page that has static content which is not expected to : ™ Right
change over time, so you do not wish to show a last Deselect e Battom

updated date at the bottom of the page.

3. Navigation Bars

If you do not use shared borders with navigation bars, you can still add navigation bars to
individual pages.

» Double-click to open the file Program2.htm

* Click into the body of the page near the bottom

* From the menu, select Insert - Navigation Bar
» Select ® Same Level

» Select ® Horizontal and © Buttons

» View the results.

Remember the advantage of shared borders is that each page has a uniform navigational

structure which can be helpful to users of your site. However, it may not work for all sites or
all pages in a site.

4. Adding and Deleting Pages

You can easily add and remove pages from your course web as needed. Eile Edit ¥

Adding a page EF > -
O

* From the menu, select File > New - Page L @ Weh
 Or from the toolbar, click on the down arrow and select Page. -

« Or right-click in the white area below your files in the folder pane Foleler
and select New Page from the floating menu. Task
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4. Adding and Deleting Pages (cont.)

Adding a page (cont.)

» The Normal Page icon will be highlighted
* Click OK.

* Note that the page includes the shared borders you have defined.
» The name of this page is new_page_1.htm
» The page will not appear in your list of files until you save it.

» From the menu, select File > Save

» Type an appropriate name for the page, such as addpage.htm
* Click Save

* Note that the new page now appears in your folder list.

Adding a new page to your navigation:

+ Select Navigation view

« In order for this file to appear in the navigational links, you need to position it within the
structure of your web.

« Select the file from the folder list and drag it onto the navigation view at the same level
as Program 1, Program 2, and Program 3 to just past Program 3

* Note that the title of the file is New Page 1

* Click to select that icon. T
« Click again to edit the title
» Type Program 4

Programs

» Return to Page view I [ [ /

» Double click on Program] 1 Program? ] ‘ Pragram3 ] [Program 4|
Programs.htm

* Note the links in the left
shared border now include Program 4

Deleting a page

+ Click on addpage.htm in the folder list to select it.

* Press the delete key
or from the menu, select Edit > Delete
or right-click on addpage.htm in the folder list and
select Delete from the floating menu.

« Confirm that you wish to delete the file by clicking Yes.

* Double click on Programs.htm
* Note the links in the left shared border no longer include Program 4
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5. Importing an HTML file

To import a file that is already in HTML format:

« From the menu, select File > Import
« Click on the Add File button.
 Browse to the location of the file.

For this class: Classfiles on Athena — ITS » FrontPage — Files to Import
« Select WebCTTips.htm and newbanner.jpg

« Click Open.
 The file will be listed in the Import list. (You may still add additional files to the list at this point.)
- Click OK.
Information Thl

» Use the &

Navigation view T

to position the ' ' ' N

file within the Mews I}‘I Fersonnel Frograms

structure of your = =

web. | |

WebCT Tips Frogram? | Frograms Frogram3

» Double-click to open the file.

» Add shared borders by selecting
Format —» Shared Borders
« Select Current page and be sure the top, left,
and bottom borders are selected.
 Select Reset borders for current page to web

default.
» Click OK
* View the results.

6.

Importing Word and Excel Documents

Shared Borders

Apply bo:

\

" Al pages
¥ Cunent page

...................

___________________

¥ Fleset borders for curent page to web default

W Taop
¥ | Ielude rmavigat
v Left
¥ | [relude navigat
™ Right
¥ Eottom

« Open program3.htm

« Place your cursor in the
body of the page.

e From the menu,
select Insert — File

File name:

E————SSS

Open

Filez af type: I.-’-'-.II Files [*.7]

- HTHL Files [#.htrn:* hikml] :I' :...,

Cancel

5

« Select Files of type: All Files (*.*)
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6.

Importing Word and Excel Documents

» Browse to the location of your file and double-click to open it.
» For this class, Classfiles on Athena = ITS - FrontPage —
Files to Import > Dept Supplies.xls or ClassEmailDisLists.doc
» Note that not all of the formatting is preserved. Each carriage return is a new paragraph.

You can also simply cut and paste from another document, if you have it open at the same

time. However the HTML code that is created may be different than you expect and you
may still need to edit your file.

Using Tables

Tables allow you to position text and graphics more precisely on your page.

Create a new page:

 Right-click in the white area below your files in the folder pane and select New Page
from the floating menu.

 Or from the menu, select File > New — Page or use the toolbar icon.

» The Normal Page icon will be highlighted

* Click OK.

Create a table in the new page:

From the menu, select Table = Insert - Table

In the Insert Table dialog box: Insert Table K
» Set the number of Rows to 4 | iz -~
and Columns to 2 oz 4 _:I Columms: |2 _Ig
» Set the width to 75 Laout

®@In percent Aligrment; IDefauIt vI ¥ Specify width:
. Baorder size: |1 j: I?  |n pixels
Select the Layout options: AR =l 3 % In pescent
. . Cell padding: I2 _IQ
» Alignment of the table hori-
zontally on the page can be de- | Cellspacing |2 —
fault, left, right, center, justify
+ Set the Border size to 1 Style... | | oK | Cancel
Tip: Use 0 if no borders are desired.
¢ Click OK.
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7. Using Tables (cont.)
Definitions:
Cell padding: The amount of

the border.
Cell spacing:

Specify width:

space in pixels within the cell between the contents and

The amount of space in pixels between the cells in the table

If you select pixels, the size of your table will be the same no matter what

size the monitor is. This may require users to scroll to see the entire table.
If you select percent, the table will be scaled to the size of the viewing
area. This may mean that text wraps within a cell.

Topic Location
* Type some
content into your Shared Borders Format Menu
table, such as
this — Tables Table Menu
Inzerting Files Inzert Menu

» Use the formatting toolbar
alignment, efc).

Cell Properties:

to format information within each cell (bold, font size,

To define the properties for a cell: From the menu, select Table = Properties — Cell
or right-click in a cell and select Cell Properties from the floating menu.

Horizontal alignment within the
cell may be default, left,
right, center, justify

Vertical alignment within the
cell may be default, top,
middle, baseline, bottom

Rows spanned creates cells
that span multiple rows.

Columns spanned creates cells
that span multiple
columns.

Width of the cell is in pixels or
percent.

Border colors or Background
colors or a graphic can
be selected.

Layout -
Horizontal aligrment: IEenfer vl W Specify width:
Vettical aigrmert  [Detat v ] [50 ‘K....-fr: ::m
Rows spanned: 1 = ™ Specify height:
Comns spanned 1 =] i (R E A7
™ Header cel R
™ Mowap
Borders
Color W fuomsic ]  Lshtboder [ Auomatc +]
Daik border: B Adonaic -
Background S elect colors if desfed
Coke =
™ Use background pictue
| Browse.., | Frapeties I
s | [ ok | concel | apob |
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7.

Using Tables (cont.)

Create a table from the table icon:

» Click on the table button in the toolbar

* Drag to select the number of rows and columns needed.

In this case, 3 rows and 4 columns.

To insert rows or columns:

» Click into a cell.

* From the menu, select

Table - Insert —»
Rows or Columns

+ Select Rows or Columns
» Select the number of rows/columns

» Select the location
(above/below the current cell selected).

Insert Rows or Col... [ E
* Rows “«

Murnber of rows;

Lacation:

Help
=l s

=

EEEN

EEEN |
EEENE |
L]

| 3by4Table

" Columnns

=l

" Above selection

% Below zelection

Create a table like the one shown here.

To split a cell:

» Click into a cell.
* From the menu,

select Table —
Split Cells

To merge cells:

» Select the cells
to merge.

* From the menu,

select Table —
Merge Cells

o[ ] coen |

‘This table began with 3 rows and 4 columns.

Two more rows were added.
Thiz row of cells was merged.

Tou can create many effects by
merging and splitting cells. This cell
merges 4 together.

This cell spans : :
Thiz cell was spht
Twro rows. 3
mto two rows.
Thiz cell || mto 2

was split |columns.

The size of a cell
expatds with the
amount of text
entered mto it
This has an effect
on other cells m
the same row.

ot tmuch to say
here.

This cell spans two columns
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8. Inserting Images and Clip Art

You can insert an image from a any digital source. If you have a picture that you would like
to put on your web site, scan it in, save it as a .jpg, and insert it into your web page.

You can also use graphics from the web. While viewing an image in a web browser, right-
click on the graphic and choose Save Picture As... Save the graphic to your hard drive
where you can later import the picture into your web site or save it to the directory where
your web site exists. Be sure to only use images that are not copyrighted or that are avail-
able for general use.

Common Graphic File Formats
GIF (Graphic Interchange Format) - pronounced “jiff’
JPG (JPEG - Joint Photographic Experts Group) - pronounced “jay-peg”

GIF JPG (JPEG)
Best for graphics Best for photographs
(with large sections of solid colors) (or any graphic with high levels

of color and hue variation)

256 colors per image 16.7 million colors per image
Larger file size Smaller file size
Retains data if compressed Becomes blurry or distorted if compressed
One-color transparency No transparency support
Animation support No animation support

To insert a picture from a file on your computer:

* From the menu, select Insert = Picture - From File

* Click on the Select file on your computer icon = g.@l

+ Browse to locate the file. For this class, Select a file on yourTomputer
Classfiles on Athena — ITS - FrontPage - Images

* Click OK.

To add alternate text for those using screen readers or without graphic capabilities

 Select the graphic

* Right-click on the graphic and choose Picture Properties

or from the menu, select Format — Properties

» The Picture Properties box will open.

« Under Alternative representations in the Text: box type a word or phrase to describe
the picture. This is what will be viewed by someone who cannot see the graphics and will
be the description a screen reader uses.

» Click OK
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8. Inserting Images and Clip Art (cont.)

You can also insert clip art from the Microsoft Clip Art gallery.

« From the menu, select Insert - Picture — Clip Art...
» Browse to locate the clip art you want and click on it
* In the pop-up menu, click on the Insert Clip icon

(the first icon on the menu)

Note that not all clips are available in the PC labs.

9. Inserting Themes

Microsoft FrontPage offers a variety of themes that you can apply to your web. Themes
apply a common structure and format to your entire web site by automatically adding the
same images, backgrounds, and styles to give your web a uniform look and feel.

e From the menu, select Format > Theme
» Choose the theme that you want to apply to your web site.
* Click OK

When you choose to apply a theme you will see a warning box letting you know that by
applying the theme it will change the way fonts, colors, bullets, and lines appear in all pages.
If you choose to add a theme to your web site click Yes.

: Themes x|
Apply Theme to; SampJE\DfTheme:
e =

L[ pages —
" Selected page(s) r.‘...- 00, 0. .00, 0,0.0_.900_0,0.0_0°9%
2

Canstruction Zone ;I a o o idé o Ba n n e r:
Corporate ”» b Fe Rl FYPTRI eV
Cwpress
Doweritowen
Exieditign / | Q Button Q Button Q Button
Folio I
Geared Up Factory 1 |
Glacir Heading 1 Style
Global Marketing
Hafwa =l ¥ Bullet 1
¥ ‘ivid colars ."B%l |'~|?|t 1:23

e

V¥ Active graphics
i Background picture

- . Heading 2 Style
PpLsuzing -
- - “| | _’|_|

[Felete | Modify =+ | OF. I Cancel |
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10. Getting Help

* To learn more about HTML and publishing on the world wide web, check out some of the
online resources available as links from the TTU Home Page - Web Publishing Info
http://www.tntech.edu/www/gen/web_publish/html.html

* The home page of the World Wide Web Consortium (W3C®) which oversees the
development of Hypertext Markup Language and other topics relating to the web is
found at:  http://www.w3.org/

* You will also want to validate your page to check for any errors in coding by submitting
each page's URL to the validator program at the W3C:

http://validator.w3.org/

* Information on making web pages more accessible is also available at the W3C site:

http://www.w3.org/WAIl/

* To learn more about Microsoft FrontPage:

From the menu select Help - Microsoft FrontPage Help.

» To request a web directory for a department, organization, or for instructional materials,
please fill out an application form available from the TTU Home Page - Computing -

Forms — Web Directories

" Microsoft FrontPage Help
o~ - 806

Contents |&nswerWizard | Inclex |

@ Designing YWebs

@ Designing Web Pages

@ Authoring HTHL

@ Ensuring Wek Corpatibility
@ Analyzing Webs

@ Publishing Webs

@ tanaging Webs

@ Getting Around in FrontPage
@ Using FrontPage in Warkgroup
@ Using FrontPage with Office

B A At s e il
< | | >

ICroso

Welcome to Help

= Use online Help to learm more
about FrontPage 2000 features

* Quickly find answers to questions
uging the Answer Wizard

* Connect to the Web for the latest
tips and product updates
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