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1. Introduction

Using FrontPage 2000 you can create simple web forms and retrieve the information via
email or a file. More elaborate forms may require the use of additional methods (ASP, VB
Script, etc.) and will not be covered in this class.

2. Opening FrontPage and Creating a New Web

In the labs from the Start menu, select Programs = MSOffice 2000 -
Microsoft FrontPage.

File Edit “iew |nsert Format Tools Table Fral

[ M [ Page. Cirl+M

= Open.. Chl+0
Close Cirl+F4

* From the menu, select File » New = Web

» Under Web Sites, select One Page Web

 Type the name for your new web:
U:\FormsWeb

* Click OK

* Note the message that FormsWeb is being created.

Fm Erlder

3. Creating your page

Double-click on the file index.htm to begin editing it.

Create a borderless table at the top with one row and two columns.
From the menu, select Table = Insert = Table

In the Insert Table dialog box:

« Set the number of Rows to 1 and Columns to 2
« Set the width to 100 ® In percent

» Set the Border size to 0

« Click OK.

Click in the left cell of the table,
» From the menu, select Insert = Picture = From File =l Q)@
« Click on the Select file on your computer icon |Select afile on yourEomputer
» Browse to locate the file. For this class,
Classfiles on Athena - ITS - FrontPage Forms - Images - j0078817.gif
» Click OK.
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3. Creating your page (cont.)

Click into the right cell and type as shown below. Remember to use a line break to keep
the lines single-spaced (Shift+Enter).

Tennessee Technological University
HOMECOMING PARADE ENTRY FORM

Saturday, October 5

Below the table, center and type:

ALL ENTRIES MUST BE SUBMITTED BY MONDAY, SEPTEMBER 30 AT 4:30 P.M.

4. Creating aform

* Fromthe menu, select Insert » Form -
Form

* Note the dotted lines show the form area.

» Enter a couple of times before the two
buttons to create some area to work in.

e Click in the first line.

To help with positioning items in your form:

From the menu, select Table = Insert = Table

In the Insert Table dialog box:

h Component

Database
I

Advanced [abl One-Line Text Box
Picture 4 scrolling Text Box
File. .. ¥ Check Box
Bookmark. .. & Badio Button

@ Hyperlink... =B Drop-Down tMenu

Ll v v

-

Ctri+H.

— Push Button
Picture...
A Label

ot Breperties. .

» Set the number of Rows to 8 and Columns to 2

« Set the width to 100 ® In percent
» Setthe Border sizeto 0

E1E3
T —

I8 g

CDIu—r:r:&\*IE 3:

IDefauIt VI
IU 3: - 100
|2 3:

¥ Specify width:
 In pixels

\/5' In percent

-

-

» Click OK.
Insert Table
In the first cell of the table, size
type: Entry Category Pl
(select one): Layout
Alignment:
« Click into the right cell in Border size:
the top row »
« From the menu, select Cell padding:
Table - Split Cells Cell spacing:
* Into 6 columns.
» Click OK Sy, |

(0]:8 I Cancel
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5. Radio Buttons

Next we will create a radio button which allows one choice to be made among the three
Entry category options: Open division, University division, Community division.

* |n the third cell of the first row,

= Component 3
type Open . ] Datahase »
* In the fifth cell, type University
* Inthe last cell, type Community Advanced 2 = _Or Drag'to make this menu fIDat|
: Pict » Bl Scrolling Text B
From the Insert menu, click on the top EIEHE &l Seraling Text Box
File. .. V' Check Box
blue bar of the Form submenu and _
Bookmark. .. & Badio Buttan

drag to create a floating Forms menu.

. Hyperlink...  Cirl+k =R Drop-Down kMenu

+ Select Radio Button. Form
* Right-click on the radio button and select Form Field e i ol | = - T e % |
Properties from the floating menu.
Radio Butt0n|
* Inthe Radio Button Properties  |[RLREEN 0TI HEl
window, type the group name, Group name: [EnryCetegory
EntryCategory This should
not contain any spaces. valie: [oper
* Type the value: Open Initial stats: € Selected & Motselectad
» Settheinitial state: Not Tab order [

selected

+ Setthe Tab order: 1 Sye. | Velidste.. | ok | cancsl |

* Click on the Validate button

. . .. Radio Button Yalidation HE3
* Type a display name that is descriptive
(you may use spaces). Display name:  [Entry Category
. Sglect Data required ¥ Data required
» Click OK

Ok, | Cancel
» Click on the radio button to select it and
copy and paste it into cell 4 and 6 in the first row.
* Right-click on the button in cell 4 and select Form Field Properties
» Leave the Group Name the same, but change the Value to University
and the Tab order to 2
* Right-click on the button in cell 6 and repeat by changing the value to Community
and the tab order to 3

YBScript: Yalidation Error

This validation message that would appear if
someone did not enter a value for Entry Flease select one of the "Entry Categony" options.
Category on your form.

Ok

» Save your file and try it out in preview mode.

Information Technology Services October 2002



FrontPage Forms

Page 4

6. TextBox

In the second row left cell, type:
Organization’s Complete Name:

from the floating Form menu.
Right-click on the text box and
select Form Field Properties
from the floating menu.

In the Text Box Properties
window, type the field name:
OrgName

Set the Width of the field at 55
Set the Tab order at 4

Note: If password field is set to yes,
asterisks appear on the screen

In the second row right cell, select One-Line Text Box

Text Box Properties

Form

One-Line Text BDX|

MName: IOrgName

Initial walue: I

Width in characters: |55 Tah order; |4
Fassword field:  Yes  [\ao
syle.. | [ validate.. | ok | cancal |

instead of the characters which are

being typed. It only provides a mask at the screen and does not encrypt the information being

provided in any way.
Click on Validate

Select Text as the Data type

Click OK
Click OK
Display name:

You can resize a form

Text Box Yalidation

Type a Display Name which will appear when validation fails: Organization’s Name

Set a minimum length to ensure that something is entered in this field: 2
Set a maximum length to prevent misuse of your form: 55

2] x|

IOrganizatiDn's Mam

—

. Data type: IText
field as needed:
Text farmat
: . [T/ Lett I Whit
« Click on the text field - D? t - oml Sepeee |
QIS =]

and use the handle d

on the right side to Mumeric farmat

make the entry box Grouping: @ Comms. € Period € hone

smaller. Decimal; ! Comme ! Period
« Right-click onthe Data length O

field and select Form
Field Properties from

tdin length: I2

¥ Required

hax length: I55

Data walue

the floating menu.
Note that the Width in
characters has
decreased. This does

[~ Field must be;

™ And must be:

—
—

IGreaterthan or egual to j “Walue:

=

ILessthan or egual to “Walue:

not affect the I—IOK o |
. ancel
maximum length set
for validation purposes.
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7. Drop-Down Menu

Form X
* Inthe third row left cell, type Type of Organization: CmER & @l_, Al

* In the third row right cell, select Drop-Down Menu
from the floating Form menu.

Drop-Down kMenu

+ Right-click on the Drop-Down Menu and select Form Field Properties from the

floating menu. Drop-Down Menu Properties HE
* Inthe Drop-Down - [Typeor
Menu Properties Name: |11 ?
window, type the field Chaice | Selected | Value | Add
. Select One: Mo
. Cickagd 2 o v |
+ Type the Choice: Paolitical Mo Remove |
Community gggiﬁll:le EE b 1 |
 If you want to store a i
different value than the Move Down |
choice Iabel’ you may Height: |1— Allow multiple selections: T Yes
select Specify Value &
and type a value. Tiela ezt o \ N
« For the Initial state,
select Not selected Stle. | Validate. | ok |  cencel
+ Click OK
Add Choice HE
Choice:
[Community + Click Add again and repeat for each of the
_ choices shown above. Note that you can position
‘W your choices as desired by selecting the item and
| / using the Move Up and Move Down buttons.
Initial state: » Under Allow multiple selections, click No
 Selected / + Setthe Tab orderto 5
* Mot selected » Click Validate
(0]4 | Cancel

Drop-Down Menu Validation |2 | x]
° Type the D|Sp|ay Name Type Of Display name: ITyF'E'-' of Organizatinn
Organization |
+ Check Data required FiRaaEciiedidy
« Check Disallow first choice since that is | ¥ Disallowfirst choice
just the instruction line “Select one:” ’TI el
* Click OK
* Click OK
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8. Add Text Boxes

In the next rows, in the left column, type
Person Completing Information:
Address or TTU Box No.:
Phone:
Complete Email Address:
In the corresponding right cell, select One-Line Text Box from the floating Form menu.
Use the field names: Name, Address, Phone, Email
Set the field widths and tab order
Set up validation for each.

9. Scrolling Text Box

In the last row left cell, type Description of Entry:

In the last row right cell, select Scrolling Text Box Form B

from the floating FOormmenu. | &
Right-click on the scrolling text box and select Form

oS
Scrolling Text Box

Field Properties from the floating menu.

In the Scrolling Text Box Scrolling Text Box Properties HE
Properties window, type the Mame: |Description

field name: Description - _

Set the width to 40 characters it velue: B
Set the number of lines to 5 T

Set the tab order to 10

Click on Validate

Set a display name:
Description of Parade Entry
Set a minimum and maximum
entry length

Click OK

Click OK

WWidth in characters: Tab order:

[
e

o |

Murnber of lines:

Style... Yalidate... | Cancel |

Browser sometimes differ in how they handle form fields. In the case of scrolling text
boxes, earlier versions of Netscape (i.e. 4.78) will not wrap the text in the box unless
you make a small change to the HTML.

Click on the scrolling text box, then click on the HTML tab to edit the code.
Add the word wrap in the textarea tag: <textarea wrap>

Return to the Normal view.

Click on the Preview tab and view your form, note that some elements will not be active
until your form is published. If needed return to Normal view and autofit the table and

center it.

Information Technology Services
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10. Setting Form Properties

Right-click in your form and select Form Properties from the floating menu.
By default your form information is sent to a file in the _private folder on your web site.
You can also add the option to receive the information via email.

Type in your email

Form Properties 2 [x]
address.
Where to store results
. . ' Sendto
» Click on the Options , _
File name: I_prlvate,-"fc:rm_results.bd Browse... |
button

Under the File Results
tab, select the format in
which to save your
data: Text database
using comma as a
separator

E-mail address:

¢ Send to other

Form properties

Iewells@tntech.edu

" Eend to datahase

ICustDm [ZAF] MNEAFL CGl ar ASF Script

« Under the E-mail Form name: |Parade_Form

Resglts tab, select the Target trame: | ___p,l

email format
+ Type asubjectline

. Options... | Advanced... | Ok | Cancel |

* Type areply-to line.

(Note this could be a

field name, such as Email, if Options for Saving Results of Form X

you need to reply to the person
who submitted the
information.)

Options for Saving Results of Form

File Results E-mail Results | Confirmatian Page | Savg

E-rmail address to receive results:
Iewells@tntech.edu

E-mail farmat:
[HTHL bulleted list

¥ Include field names

File Fesults | E-mail Results | Caonfirmation Page | Sawved Fields |

Browse... |
[

File name:

|_p rvate/form_results td

File format:

Text database using comma as a separator

HTrAL

HTRL definition list

HTRL bulleted list
Formatted text within HThL
Formatted text

Text database using comma as a separatar
Text database using tab as a separator
Text database using space as a separator

Etdail message header:

Subject line:

[ Form field name

Click OK

IHDmecuming FParade Entry

Reply-to line:

[ Form field name

Click OK

Iewells@tntech.edu

o |

Cancel
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11.

Publishing Your Form

« From the file menu, select Save to save the changes to your file.
» From the file menu, select File = Publish Web

» Forthis class use the site: http://www.tntech.edu/acs01

+ Click Publish

(through acs15)

» For this class, type ttultrainingxx as given to you by the instructor

and password

» View your web site in the browser.

» Enter some data and submit it.

* Note that FrontPage automatically creates
a confirmation page for you.

* Open another browser window and
login to your email account using
Webmail.

+ Check for messages received.

+ Return to FrontPage and close your local
copy of the web.

+ Select Open Web and type the URL of
your site.

Form Confirmation

Thank you for submitting the following information:
EntryCategory: University

OrgName: Information Technology Services
TypeOrg: Service

Name: Elaine Wells

Address: 5071

Phone: 6526

email: ewells@tntech.edu

Submit: Submit

Description

A giant computer sailing through the goal posts.
Return to the form.

« Look in the folder _private and click on the file form_results.txt to view the data you

submitted.
+ Save the file to your U: drive

» Open Excel

* Open the form_results.txt file on your U: drive

» Follow the wizard to convert the data to an Excel file.

Remember that if you republish all pages in your site, the data in the form_results.txt file
will be erased. Decide how you will keep track of new data coming in.

Information Technology Services
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12. Creating Your Own Confirmation Page

» Open the local copy of your web site from the U: drive
+ From the menu, File = New = Page or click on the new page icon in the toolbar.

« Save the page as ConflrmPage htm B N N _
-_-|:| Mpanent .
- Create a page similar to that shown mSr— # % Office Spreadsheet
= Hy Office PivotTable
beIOW . Farm 4 :
+ To insert form fields, from the menu, Advanced , i Office Chart
select Insert > Component - __ Banner Ad Manager. .
Confirmation Field (These are Bicture > 3 Hit Counter
webbots and cannot be typed in simply EHEL ) 5 Hover Button. ..
as they appear. SELSEoo E= parguee...
y appear,) @& Hyperlink..  Ctrii g
oMl Confirmation Eield. ..
m Include Page. ..

Thank you [Name]
for your TTU Homecoming Parade Application
for the [TypeOrg] Organization: [OrgName]
See you in the parade!

Return to Form

To set this page as the confirmation page:

+ Right-click in your form and select Form Properties
» Click on Options

« Under the Confirmation Page

tab, type the name of your —
page or browse to it. File Results | E-mail Results Confirmation Page | Sawved Fieldsl

Options for Saving Results of Form 2 [x]

. LIEL of confirmation page (optional):
* Save_yourflles . ICanirmPage.htm Browse. . |
* Publish to your web site

Fage displayed when the user successfully subimits the farm.
A default page is prowvided.

+ Open the browser to your site

and refresh if needed.
* Submit some data.
* Note the new confirmation page which is displayed.
» Check your email for another message.
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13. Getting Help

* To learn more about HTML and publishing on the world wide web, check out some of
the online resources available as links from the TTU Home Page = Web Publishing
Info http://www.tntech.edu/www/gen/web_publish/html.html

» The home page of the World Wide Web Consortium (W3C®) which oversees the
development of Hypertext Markup Language and other topics relating to the web is
foundat:  http://www.w3.org/

* You will also want to validate your page to check for any errors in coding by submitting
each page's URL to the validator program at the W3C:
http://validator.w3.org/

« Information on making web pages more accessible is also available at the W3C site:
http://www.w3.org/WAIl/

* To learn more about Microsoft FrontPage:

From the menu select Help = Microsoft FrontPage Help.

 To request a web directory for a department, organization, or for instructional
materials, please fill out an application form available from the TTU Home Page -
Computing > Forms = Web Directories

‘A4 Microsoft FrontPage Help
T - - &7

Contents |ﬂnswerWizard | |l e |

@ Designing Webs

@ Designing Web Pages

@ Authaoring HTHL

@ Ensuring Wb Corpatibility
@ Analyzing Webs

@ Publishing Webs

@ Managing Webs

@ Getting Around in FrontPage
@ Using FrontPage in Warkgroup
@ Using FrontPage with Office

o ket s N e
4 | >

-

icrosoft

Welcome to Help

* Use online Help to learn more

about FrontPage 2000 features

= Quickly find answers to questions

using the Answer Wizard

+ Connect to the Web for the latest

tips and product updates
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