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1. Introduction

In order to better understand how to create a Web Course using FrontPage 2000, it will be
helpful to know some basic Hypertext Markup Language (HTML) commands. For this
class, we will be using Notepad to create a plain text file of a sample HTML page. You could
edit an HTML file in any word processor as long as you save the file as ASCII text (Text only
format in MS Word). After we finish this, we will create the same page using FrontPage
2000.

Also, before beginning, it is helpful to review TTU’s web publishing policy. The World Wide
Web Publication Policy is available from the TTU home page under About this Web Server
- How to Become a TTU Web Provider - World Wide Web Publications Policy
(www.tntech.edu/www/gen/web_publish/policy.html).

2. Design Considerations

Hypertext Markup Language (HTML) is the basic tool for transforming text, graphics, and
multimedia files into a complete web page. In order to use HTML effectively, it is best to
have some ideas about how you would like your page to look. You can get ideas by looking
at both good and poor examples on the internet. Refer to the Web Style Guidelines available
from the TTU home page under About this Web Server - How to Become a TTU Web
Provider » Web Style Guidelines (www.tntech.edu/www/gen/web_publish/
style_guide.html). You can also contact the TTU Office of Public Affairs (tftunews@tntech.edu)
or Information Technology Services (Ineal@tntech.edu) for additional suggestions.

In designing your page:

1. Develop a plan for your pages. Who is your target audience?

What messages and/or information are you trying to deliver using the
web page(s)? How will the pages relate to the objectives of your course?
Sketch an outline of how you would like your page to look.

Construct a preliminary page using HTML and evaluate what you have.
Test your page using more than one web browser, such as Internet
Explorer or Netscape Communicator.

Revise your design.

When complete, notify other people that your web page is now online.
Course pages can be linked under Syllabi on Line.

howp
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3.

Basic Hypertext Markup Language (HTML)

HTML is a scripting language that marks up a page with formatting commands. These
commands are interpreted by a web browser and sent to the screen for viewing.

HTML consists of 2 elements:

1) Document content—What you want the user to see.
2) HTML tags—Codes that indicate document style and information, which the viewer
does not see.

Note: In some cases the closing tag is

<TAG> This is an opening tag. not required, but optional. Whenever you
<ITAG> This is a closing tag see both in this handout, it means it is
' required.

(The HTML tags are not case sensitive.)

HTML is used to define the organization of the document. It is not a traditional page layout
program. Pages will appear slightly differently depending on such things as the web browser
settings and the size of the screen that the individual is using to view your page.

You use HTML to identify items in your document, such as titles, headings, paragraphs,
links, and insertion points for graphics. HTML uses a beginning and ending tag to identify
these features.

The general form of a tag is: <TAG>Some text that you want displayed</TAG>

The browser displays the text between the tags, but not the tags themselves. Beginning
tags consist of a keyword between a less than and greater than sign. Ending tags consist of
a slash and keyword between the less than and greater than signs.

<HTML> </HTML> You will normally see these at the very top and bottom of an HTML
page, respectively. The HTML tag tells the browser, “Hey, I'm an HTML page!” Always be
sure your beginning and ending HTML tags are in place.

<HEAD> </HEAD> This tag marks the section of an HTML page where any information
that refers to the entire page is placed. In a simple HTML page, there’s only one such tag to
be concerned about and that is the <Title> tag.

<TITLE> <ITITLE> This tag names your page. The title will not appear within the window
of the page itself, but rather at the top of the browser’s interface in the title bar. This is also
the title that will show up in the bookmark file if a visitor chooses to bookmark the page.

<BODY> </BODY> This tag defines the text normally displayed in the browser window, and
controls various visual aspects of the page, such as background design, text color, link
colors, and margins. Most of the actual information that you place in your web page will be
placed between the two body tags. Remember, none of the spacing or formatting you do
within the editor will be read by the browser. To format text, you must use HTML formatting
tags; otherwise your page will display as one continuous line of text with each word sepa-
rated by a single space.
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4. Creating a Web Page in Notepad Using HTML

To begin creating a web page in HTML, open Notepad.
In the PC Labs, from the Start menu select Programs — Accessories > Notepad.

Type the HTML tags shown below with an appropriate title for your course to get your page

started:

Saving your file:

& Untitled - Notepad

File Edit Format Help

<html>
<head>«<titlexITS:Basic web Course Design in FrontPage</titlex</head:>
<hody>

</body>
</html>

Save your work to your U: user drive. From the menu, select File » Save As
Browse to the U: drive, and give the file the name index.html
Your initial web page must be named default.htm, default.html, index.htm, or index.html

Preformatted heading tags, <H1> through <H6> and </H1> through </H6>:

<H1>
<H2>
<H3>
<H4>
<H5>
<H6>

</H1>
</H2>
</H3>
</H4>
</H5>
</H6>

These increase the font size and make the text bold.

H1 is the largest font size and size decreases through H6.

These tags require an opening and closing tag around the

text that is to be included as the heading.

Heading tags generally apply a blank line before and after the text.
Under the <Body> tag, type a heading with your course name:
<h1>Course 999: Introduction to College</h1>

Inserting a Horizontal Rule, <HR>:

The <hr> tag allows you to visually separate text on the screen by drawing a horizontal
line or “rule” across the page. Under your Course Name, type: <HR>
Note that a closing tag is not required.

Using Paragraphs, <P> and </P>:

The paragraph tag allows you to separate information into paragraphs. The beginning tag
is required, while the ending paragraph tag, </P>, is optional. However, best practice is to
include it. The paragraph tag inserts a blank line above a block of text to distinguish one
paragraph from another. This is a block paragraph style.

Type a paragraph that you might use to introduce yourself to your students, under the
horizontal rule. You do not need to use the enter/return key while typing the paragraph.
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4. Creating a Web Page in Notepad Using HTML (cont.)

For example:

<P>To make things easier for you to read, press enter and type a para-
graph tag to begin each paragraph. Actually, any HTML file could be writ-
ten as one long line and the browser would decode it and display it in the
same way as if the tags and content were typed on many lines.</P>

<BR> The break tag calls for a line break. Use breaks when you want to have one
carriage return but no space between the text. </BR> is not required.

Adding Formatting to Text (Bold. Italics. Underlines):

You can use the following tags to add bold, italics, or underlining to your text. Be sure to
close each tag or the rest of your document will be formatted in that style. Within the
paragraphs you typed, go back and choose words or phrases for emphasis using these:

<B></B> Bold or <strong> </strong> Strong
<I></I> Italics or <em> </em> Emphasis
<U></U> Underline

<BIG> </BIG> This makes the text larger.
<SMALL> </SMALL> This makes the text smaller.

<BLOCKQUOTE> </BLOCKQUOTE> This indents your text from the left
so it is easier to read.

Note that you can use more than one formatting tag on the text. Close each tag in the
reverse order that you opened them: bold, underline, then close underline, close bold.

Use some of these formatting tags in the paragraphs you wrote about yourself.

Alignment of text and/or images:

<CENTER> </CENTER> This tag is used to center text or images horizontally.

Use this to align your course title across the center of the page.

<P ALIGN="right”> These tags are used to align a paragraph to the right, left, and center.

<P ALIGN="left”> You must use the closing </P> tag to end the alignment.
<P ALIGN="center”>

<DIV> </DIV> This is the division tag. Use this tag when you want to set the align-

ment for more than one paragraph or heading at a time. By itself it
does cause any formatting effects.
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4. Creating a Web Page in Notepad Using HTML (cont.)

For example, to carry a specific alignment through several paragraphs, use one of these:

<DIV ALIGN="right”> </DIV>
<DIV ALIGN="left”> </DIV>
<DIV ALIGN="center”> </DIV>

Formatting Text Exactly as You Enter It, <PRE> </PRE>:

To maintain the formatting of text exactly as you have entered it, you may want to use the
preformatting tag. For example, to enter an address:

<PRE>
Address: Information Technology Services
Box 5071
Cookeville, TN 38505
Phone: (931) 372-3387
</PRE>

Save your file to the U: drive. From the menu, select File > Save.

& index.html - Notepad =10O] x|
File Edit Format Help

<html: -
<head>«titlexITS:Basic web Course Design in FrontPage</titlex</head:
<hody>

<centers

<hl><u>ITS: Basic web Course Design<br> in FrontPage Z000</u></hl>

<j/centers

<hrs

<p>Type a paragraph wou might use to <izintroduce</i> wourself to wour

students. Use some of the <strongs<emsformatting«</em></strong:> tags

to see what effect they have. </p>

<blockquotex<i»A pithy quote here might introduce students to wour philosphy

of Tearning for wour particular subject area or field.</i></blockquotes

</bodys
</html= -
4| | Y]

5. Viewing Your Web Page

[=] - Minimize your file in Notepad by clicking on the minimize button in the upper right corner.
« Open a web browser.
* In the PC labs, double click on the Internet Explorer icon on the desktop.
e From the menu, select File = Open.
+ Click on the Browse button and locate your file index.htm on the U: drive.
+ Highlight the file to select it and click OK.
* You should now see how your page would appear on the web.
* Minimize Internet Explorer
« Maximize your index.htm Notepad file to continue editing.
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6. Using Lists in Hypertext Markup Language (HTML)

You can create either an ordered (numbered) or unordered (bulleted) list to set off items. An
unordered (bulleted) list begins with the tag <UL> and ends with </UL>. An ordered (hum-
bered) list begins with <OL> and ends with </IOL>. The items in either list begin with the list
item tag <LI>. The item ending tag for an item is optional and is usually omitted.

<]
<]i>To gain knowledge of some basic HTML
<1i>To gain knowledge of the FrontPage toolbars

< /U

<h3>Course Topics:</h3>
<0 1>

<]i=Basic HTML
<]ixUsing Lists
<1i=FrontPage Wiews
<lixUsing a Template
</ol>

</bodys

</htmls

il |

" —
& index.html - Notepad - |E|| il
File Edit Format Help
<h3>Course Objectives:</h3> A

<1i>To know how to move between a WYSIWYG and HTML wiew J

-

M4

Create an unordered (bulleted) list of your
Course Objectives using <h3> </h3> and the
<UL> and </UL> tags.

Create an ordered (numbered) list of your
Course Topics using a heading and the <OL>
and </OL> tags.

 Another kind of list is a definition list. It begins with <DL> and ends with </DL>. In this list
style, the definition term <DT> appears on one line and the definition description <DD> on

the next line is indented automatically.

« Save your editing changes. File - Save

b MaXImlze your browser screen and take a |00k at Type a paragraph you might use to iztroduce yourself to your students. Use
these additions to your page.

« To update your browser screen, be sure to click on

Refrash

Communicator.

7. Adding Images <IMG>

Refresh in Internet Explorer or Reload in Netscape

ITS: Basic Web Course Design
in FrontPage 2000

some of the fermaiiing tags to see what effect they have

A pithy quote here might introduce studsnts io your philosphy
af learving for your particuiar subject area or field.

Course Ohjectives:

* To gain knowledge of some basic HTML
* To gain knowledge of the FrontPage toolbars
* To know how to move between a WY SIW TG and HTML wew

Course Topics:

1. Basic HTML.

2. Tsing Lists

3. FrontPage Views
4. Tsing a Template

<IMG> This is the image tag, it alerts the browser that an image needs to be loaded. It

does not require a closing tag.

SRC This attribute stands for source or image source.
You insert the actual name of the graphic file you want to be displayed.

ALT This attribute means alternate text. This will appear instead of the image in text-
only browsers, such as Lynx. The text will also appear when the mouse arrow is
placed on the picture in a graphical browser like Netscape or Internet Explorer.

Example: <IMG SRC="Mylmage.jpg” ALT="My Image”>
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7. Adding Images <IMG> (cont.)

Copy a graphic image of a small house to your U: drive.

* Open Windows NT Explorer. Start > Programs — Windows NT Explorer
* Browse to Classfiles on Athena

» Select the folder ITS - FrontPage

* Right click on home.gif

» Select Copy

* Browse to the U: drive

* Right click and select Paste

* Close Windows NT Explorer

* Maximize Notepad.
* Insert a horizontal rule <HR> at the bottom of the body section.
 Below that insert your house image:

<IMG SRC="home.gif” ALIGN="middle” ALT="TTU Home”>
The ALIGN attribute can be set as bottom, middle, or top to align the image vertically

within the context and current baseline. You may also use left, right, or center to indicate
the position horizontally across the page.

8. Adding Links

Alink is a hypertext reference on your page that will connect the user to a page somewhere
else, either on the Internet or on the same computer. Your course page should include a link
to return to the TTU Home Page and a link to your email address. To add links these links,
use the Anchor Tag, <A> </A>.

The <A is followed by a reference comment, HREF, and the name of the page or the URL
where the page you are linking resides. After closing the initial anchor command, type in the
text you want to have highlighted as a link when the page is viewed. Then close the tag with
the companion </A>.

At the beginning of the line with the house image, type the reference to the TTU Home Page,
followed by text that will appear (TTU Home Page) and end with </A>

<A HREF="http://lwww.tntech.edu/"><img src="home.gif" alt="home">TTU Home Page</A>
Absolute Linking:  This uses the absolute URL, (Uniform Resource Locator) an exact
pointer to the location, directory, and page where the information you want to link to resides

when it is not located on the same computer.

Example: <A HREF="http://lwww.tntech.edu”>Tennessee Tech University</A>
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8.

Adding Links (cont.)

Relative Linking: This is used when you create a link from one page to another page
on the same computer. It is not necessary to specify a complete URL.

Example: <A HREF="course/requirements.html|”>Computer Science 101</A>

Adding a link to your email address:

It is helpful to viewers to know who to contact and who maintains the page. Add another
horizontal rule and then add your email address as shown below, substituting your own
name and email address.

Example: <A HREF="mailto:username@tntech.edu”>Your Name</A>
Users will also want to know how current your page is, so add a line indicating when it was

last updated as shown below. Then maximize your browser, refresh, and note how this
appears to the viewer.

<a href:=

<hr>

<p>This page is maintained by <a href="mailto:username@tntech.edu”>Your Name</a><br>
Last updated on May 16, 2000</p>

</body>
</html>

“http://wew. thtech.edu/"><img src="home.gif" alt="home”>TTU Home Page</a>

Home Page

This page is maintained by Your Name

10.

Last updated on May 16, 2000

Save your file and exit Notepad.

Indicating the Version of HTML in Use

Prior to the beginning <HTML> line, it is recommended that you indicate which version of
HTML the document is written in. The HTML used here is based on version 4.0 Transitional.
As the first line in your index.html file, type:

<IDOCTYPE HTML PUBLIC “-//W3C//IDTD HTML 4.0 Transitional//[EN”>

For more information on HTML standards, see: http://www.w3.org/

Other Useful HTML Codes

Character Numeric Code Description
. &#183 Middle dot
& &#38 Ampersand
© &#169 Copyright
® &#174 Registered trademark
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11. Opening FrontPage 2000

8] Microsoft FrontPage

Fle Edit wiew [nsert Format Tools Table Frames Window Help

In CH313C, from the Start menu
select Programs — MS Office97 -
Microsoft FrontPage 2000.

Note that the program opens a new
blank page for you in Page view. This
is the basic text and layout editor for
formatting your web page content.

At the bottom of the sheet are three
tabs. You may view your work in Nor-
mal mode, in HTML mode, or in Pre-
view mode.
Normal The view you will most often
use. This is the view in which
you develop your pages.

HTML

IIE

A IEEE R R =0 E
= E

hl)
J(None) '\ w (default font) ™ Mormal v| B I U | z

| |
== (=i :‘Ef‘i'i"|

Wigws
|

Fage
il

Folders

s

new_page_1.htrm

\Standard Toolbar

\

Page View Formatting Toolbar

Mavigation

B

Hyperlinks

ng
k

Tasks

Tabs to Document Views

m

The view in which you can see and edit the HTML code of your document. [f you

are familiar with HTML, there may be some tasks that you are more comfortable

performing in the HTML tab.

Preview

Displays a close approximation of what visitors to your site will see through their

Web browser. NOTE: The preview tab is an approximation and cannot mimic with
100% accuracy what visitors to your site will see.

Before you begin, click on the HTML tab. You will see some beginning code is already
present that defines this page as an HTML document. Click back to the Normal tab.

Formatting Toolbar

Note the familiar formatting toolbar which includes the following:

A drop-down menu that allows you to change the text style. It includes the

heading styles 1 to 6, bulleted and numbered list and other options.

A drop-down menu that allows you to change the text font. If you select

default, the text font will default to that selected by the user for his/her browser.
Remember to select common fonts found on both PCs and Macintosh
computers for the broadest access to your page as you designed it.

Style
Font
Font Size
Bold Bold faces fonts
Italic Italicizes fonts
Underline Underlines fonts

A drop-down menu that allows you to change the size of the font
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Align Left  Aligns text with the left margin
Center Centers text horizontally across the page
Align Right Aligns text with the right margin
Numbering Creates an ordered list (i.e., 1., 2., 3., 4., etc.)
Bullets Creates an unordered list (i.e., a bulleted list)

Decrease Indent
Increase Indent
Highlight Color

Font Color

Standard Toolbar

Sets the current margin for lines of text further to the left
Sets the current margin for lines of text further to the right
Sets the background color of the selected object or text
Sets the font color

The standard toolbar includes:

New Page

Open

Save

Publish Web
Folder List

Print

Preview in Browser
Spelling

Cut

Copy

Paste

Format Painter
Undo

Redo

Insert Component

Insert Table

Insert Picture From File
Hyperlink

Refresh

Stop

Show All

Microsoft FrontPage Help

Opens a new blank page for editing

Opens an existing page for editing

Saves the current page to your local machine or network
Saves and uploads the current page to your Web server
Displays a list of your folders

Prints the current page

Displays the current documents in your default Web browser
Checks spelling

Removes information and stores it in clipboard

Copies information and stores it in clipboard

Pastes information stored in clipboard at location of cursor
Copies HTML format to text

Undoes last command

Redoes last undo

Inserts FrontPage 2000 specific components (requires
FrontPage Extensions on the Web server)

Inserts a table

Inserts pictures or graphics from your local computer
Inserts a hyperlink

Refreshes the screen

Stops loading page in preview mode

Displays all hidden formats

Displays the FrontPage Help menu

12. Entering a Course Web Page

+ Click onto the document and type the name of your course.
» Click on the HTML tab to see how it has been added to the code.
» Click back to the Normal tab.

Information Technology Services
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12. Entering a Course Web Page (cont.)

Next we will enter similar information as you
did for your course using Notepad writing
in HTML.

Remember in Page View you can enter and
edit text as you would in any word proces-
sor and the HTML code is created by the

FrontPage program.
(None) (de

Mormal
Formatted
Address
Heading 1

Heading 2z

Heading 4 hi

* Select your course title.

+ Using the Style pulldown
menu on the formatting
toolbar, select an appro-
priate size.

 Center the heading usmg the centericon
in the toolbar.

«» To insert a horizontal rule, from the menu,
select Insert > Horizontal Line.

 Type a paragraph introducing yourself to
your students. Try different formatting
effects, such as bold, italics, and under-
line.

 Type a pithy quote using the Indent icon in the formatting toolbar

to move the quote in.

« List your Course Objectives in a bulletted list.

toolbar.

« List your Course Topics using a numbered list.

formatting toolbar.

ITS: Basic Web Course Design
in FrontPage 2000

Type a paragraph you might use to introduce yourself to your students. Use
some of the formatting tags to see what effect they have.

A pithy guots hare might introduce students to your plilosply
af learning for your particular subject area or fleld

Course Objectives:

+ To gamn knowledge of some basic HTML
+ To gain knowledge of the FrontPage toolbars
+ To know how to move between a WYSIWYG and HTML wiew

Course Topics:

1. Bagic HTML

2. Using Lists

3. FrontPage Views
4. Using a Template

U Home Page

This page is maintained by Your Name
Last updated on May 16, 2000

& -

it
(i
kL
il

e

A -

.i_ : S
Bullet5|

Increase Indent|

Use the bullet icon in the formatting

Use the numbered list icon in the

« Insert another horizontal line. From the menu, select Insert - Horizontal Line.

« To insert the little house image, from the menu,

select Insert > Picture » From File

mgﬂ%llolﬂ@

= Insert Pictre From FI|6E

Or on the standard toolbar, click on the Import Picture from File icon.

* Browse to ClassFiles on Athena = ITS - FrontPage — home.gif

or to where you saved it on your U: drive

Select the file and click OK.
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12. Entering a Course Web Page (cont.)

To insert a link to the TTU home page:

» Next to the house graphic, type TTU Home Page

» Highlight both the picture and the short phrase
* From the menu, select Insert » Hyperlink

* In the URL box near the bottom, type www.tntech.edu

+ Click OK.

To insert an emaiil link:

» Insert a horizontal rule. From the menu, select Insert - Horizontal Line

« Type: This page is maintained by Email Me!
» Highlight Email Me!
* From the menu, select Insert » Hyperlink

Create E-mail Hyperlink

Type an E-mail address

2l

Example: someone@micraosoftcom

+ Click on the envelope icon (see below). I
« Type your email address in the window.

Cancel

. QK I
+ Click OK
+ Click OK
|Create a page and link to the new page|
|Make a hyperlink. that sends E—mail|
[Use vour Web Browser to select a page or file|
URL: |http:/ ] []] ﬁ_l _|E JD

|Make a hyperlink to a fle on“your computer|

El

Optional
’7 Bookmark: I(nc:ne)

Target frame: IPage Default (none] o"l

]

Cancel

| Parametars... |

syle. |

To insert a WebBot that automatically notes last update:

+ Type: Last updated on

* From the menu, select Insert > Date and Time
* From the pulldown menu, select a date format.
« Click OK.

Save your file and look at it in a browser:

* From the menu, select File > Save As
» Browse to the U: drive

« Name the file default.htm

« Maximize Internet Explorer

Display:
= Date this page was last edited

" Date this page was last automatically updated

Date format: ITuesday, My 16, 2000 ﬂ

I(none) ﬂ
QK I

Time format:

Cancel |

« Click on the Browse button and locate your file default.htm on the U: drive.

« Highlight the file to select it and click OK.

* You should now see your page as it would appear on the web.
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13. Creating a Web

So far, we have used FrontPage to edit a single page. Next we will create an entire web site
based on a course template created here at TTU by Annette Littrell, Academic Computing

Support.

N

mportwek| © S€lect the Import Web Wizard icon

* Close the page you have been working on: File —» Close
@\ | From the menu, select File > New > Web

wizard | « Under Options type the name for your new web: U:\courseweb

» Click OK

* Note message that courseweb is being created.

» The Import Wizard window will appear.

« Type the location of the template we will be using:
http://Iwww2.tntech.edu/template/

 Click Next.

* Uncheck the two boxes which limit
the size of the web.

 Click Next.

« Click Finish.

" Ipart Weh WRAR - Chise Salkce x|

TR

= o3 3oL of dir=Sor = filaz or 2
£C3 Zomauber = netiat

= ory o vide ab site

| ==ainy

| Iptermnel o e =.c

[ Secareczarzdzinecy wd i35

You may see a warning message. Go ahead and click Yes to import the template.
Note the files being imported into the courseweb directory.

+ In FrontPage you will be in Page View with a list of
files and folders. No page is yet selected for edltlng | Fle Edit View Insert Format Tools Table Frames Window Hejp

» Double-click on index.htm to open it
in the Page editing window.
» The template shown below will open.

+ Fill in your own information into the page.
» Begin by replacing “Fill in your Course # and Title Here”

with your course information.

Editthe |
iproperties |
ores - Here
Navigation |
\Bar to P
idisplay D
hyperiinks |
ihera] P

XYz1001

uesday and Thursday, 2:00 pm
uilding XYZ, Room 200

Welcome to Fill in the Class here!

Select this text and replace it with your opening
¢ remarks.

5 F||||nyourCourse#andT|tIe

&} Microsoft FrontPage - C:'courseweb2

D@ - Ha[EE2RY|sRRF| o o BT
| - - <|e £ u|

Folder List |

B2 C\courseweb 2

= _private

-0 Images

-] index.htm

- sylabus. htm
& policies.htm

-] news.htm

&) homewaork htm
&) hwi.htm

-] hw2.htm

&) hw3.htm

Hyperlinks

Eg,

Note that the information about your course,
including a spot for a picture has been for-
matted with a table. This helps to align infor-
mation in HTML.

Information Technology Services

September 2000



Basic Web Course Design Using FrontPage 2000

Page 14

13. Creating a Web (cont.)

« Enter your name, email address, phone, date and time of the course.
« Type an introductory statement to your students below the table in the space provided.

* Do not edit the section that says:
[Edit the properties for this Navigation Bar
to display hyperlinks here]

Double-click on each of the files in the list to see what each contains.
Note that there is a syllabus file (syllabus.htm), a policies file (policies.htm),

a news file (news.htm), a homework file (homework.htm) as well as three

specific homework assignment files (hw1.htm, hw2.htm, hw3.htm).

14. Navigation View

[ ee——
Window Help

1 index.btm

2 syllabuis.htm

3 policies.htm

4 news. htm

5 b 3.0tm

& hw 2, htm

7 b 1.0tm

8 homework. htm

To this point, we have only dealt with the Page ed-

iting view in FrontPage 2000. Next we will ex-
plore the Navigation view.

(BRI « Click on the Navigation view icon.
« In this view, you will see the structure of your
web. At this point, it only has one file,
index.htm, which has the title Course Title.

To change the title for this file from Course Title to

~ Mavigation
100%

~® el

Goroe e )

a

This view shows the navigation structure of your Web. To
automaticaly add navigation buttons to these pages,
choose Shared Borders on the Format menu.

something specific to your course:

* Click on the label Course Title, pause slightly, and click again to select.

 Type to retitle this page.

« Remember that the title is what is seen at the top of the browser window and used by

search engines to help determine what your page is about.

4} 178 Documents: Basic FrontPage 2000 - Microsoft Internet Explorer

j File Edit Wiew Favaorites Tools Help

Note that you can also change your title from Page view:

* Right-click on your file.
 Select Page Properties from the pulldown menu.
« Click on the General properties tab.

« In the title box, type an appropriate title for your page.

Ut

o
Paste

Faste Special

Theme..,
Staned Borders,..

Fage Froperties,.,
Faragraph...
Font...

Alt+Enter
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14. Navigation View (cont.)

To include other files and build links:

+ Select the homework.htm file in the folder list

* Drag it under Course Title in the Navigation view.

* Note that a link is created from Course Title to Assignments.

» Do the same for the syllabus.htm, news.htm, and policies.htm files.

Note that you may drag and position these in any order.

 Next, drag the files hw1.htm, hw2.htm, and hw3.htm under Assignments.

« Remember that the filename can be different from the Title of the page, so note here that
the file is named news.htm, but the title of the file is Announcements and that is what
shows up in the Navigation view.

 You can change the titles of any of the pages from this view.

2

Sy\labus ASS|gmmemt3 |

Asmgmmemt 2 hl

Your structure should now look like this =

[
Arnouncern.. t]

Course Pollues

1
Assignment 3 t]

Asswgnment 1

As your structure becomes more elaborate, it is sometimes helpful to have an enlarged view.

» Right-click on your navigation page Rotate 100%
 Select Zoom from the popup menu. Expand Al 75%,
» Select the Zoom level that will best help you see your links | view Subiree Grily 50%
25%
and overall structure. e Too Page o
Lpply Changes
Web Settings...

Return to Page view to see the results:

.........................................................

* Click on Page view and return to the index.htm file. Announcements Fill in v
« Note that a navigation bar has been created with links | iCaurse Policies : Y
to each of the pages. ESyjIIabus Here

Assignments ¢ ——
In the next class we will discuss how to produce these |:

navigational links in more detail.
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Getting Help

To learn more about HTML and publishing on the world wide web, check out some of the

online resources available as links from the TTU Home Page (www.tntech.edu). Web Pub-

lishing Info provides links to helpful sites:
http.//www.tntech.edu/www/gen/web_publish/html.html

The home page of the World Wide Web Consortium (\WW3C®) which oversees the develop-
ment of Hypertext Markup Language and other topics relating to the web is found at:
http.//www.w3.org/

You will also want to validate your page to check for any errors in coding by submitting each
page's URL to the validator program at the W3C: http://validator.w3.org/

Information on making web pages more accessible is also available at the W3C site:
http.//www.w3.org/WAIl/

To learn more about Microsoft FrontPage:
From the menu select Help = Microsoft FrontPage Help.

To set up an Instructional Web Page, space will be provided on the Instructional Web Server.

Please fill out an application form available from the TTU Home Page - Computing -
Forms or contact Lauren Neal via email at Ineal@tntech.edu (phone: 372-3982).
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Summary of Common HTML Tags

HTML Tag Brief Description
<HTML>Your entire page</HTML> Identifies the page as a web page.
<HEAD>Heading Information</HEAD> Identifies the heading area of the page.
<TITLE>Title of the Page</TITLE> The title which appears in the title bar.
<BODY>Body of the Page</BODY> Identifies the body area of the page.

<H1>Text</H1> Heading Text. H1 through H6 available.
<HR> Inserts a line in your document.
<B>text</B> Bolds the text.
<|>text</I> [talicizes text.
<U>text</U> Underlines text. (deprecated)
<PRE>Preformatted text</PRE> Displays text exactly as you typed it.
<P>Paragraph Paragraph break (double space).
<BR>Line Break Line Break (single space).
<UL></UL> Unordered/bulleted list.
<OL></0OL> Ordered/numbered list.
<LI> List item.
<IMG SRC="filename.gif" ALT="text"> Inserts a graphic in your page.
<ADDRESS>Text</ADDRESS> Contains the signature of your page.
<A HREF="locationURL">Link Name</A> Link to another page.
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